Service Disruption
Incident Report for ProductPlan
Resolved
A fix has resolved this issue for the ProductPlan application.
Posted Feb 15, 2022 - 15:06 PST
Identified
This issue is affecting west coast customers only (California & Nevada).
Posted Feb 15, 2022 - 14:36 PST
Investigating
Cloudflare is currently experiencing a service disruption that's affecting ProductPlan's application.
Posted Feb 15, 2022 - 14:05 PST
This incident affected: ProductPlan Application.