One of our service providers is having an issue
Incident Report for ProductPlan
Resolved
Our third party provider has resolved the issue.
Posted 7 months ago. Jan 18, 2019 - 12:10 PST
Investigating
Our help chat system is run by a third party system and they are currently having issues beyond our control. We are in touch with their support team and will report any additional information we can share. You can reach us via email at support@productplan.com
Posted 7 months ago. Jan 18, 2019 - 12:05 PST
This incident affected: ProductPlan Application.